Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 23, 2025 - 18:08 EDT
Scheduled
On April 23, 2025, Billhighway is performing scheduled maintenance from 6:00 PM to 8:00 PM Eastern. During the maintenance window, access to production will still be available. If you have any questions or need immediate support, please contact us at support@billhighway.com
Posted Apr 23, 2025 - 18:07 EDT
This scheduled maintenance affected: API, CDN, Chapters, Docs, Forms, and Upload.