A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2026 - 11:29 EDT
Investigating
When accessing Billhighway, you and your members may experience significant processing and navigation delays. Our teams view this issue as urgent and are actively working to restore access to Billhighway. We expect platform performance will return to normal levels in the next sixty minutes.
We appreciate your patience and partnership. For immediate support or questions regarding your association’s hosting environment, please contact us at support@billhighway.com.
Posted Jul 24, 2026 - 10:47 EDT
This incident affected: API, Chapters, Docs, Upload, and Anywhere Mobile App.