Billhighway Platform Alert Notification

Incident Report for Billhighway

Resolved

This incident has been resolved.
Posted Mar 07, 2024 - 16:44 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 06, 2024 - 10:45 EST

Update

Our team is currently performing maintenance to investigate and improve the stability of our pdf document functionality on the platform. During this period, there may be temporary disruptions to downloading pdfs, check creations, generating new invoices and statements. Any check creations and invoice generations requests during the maintenance window will be queued up and generated after the maintenance.
Posted Mar 05, 2024 - 17:12 EST

Investigating

When accessing Billhighway, you and your members may experience issues with check printing and viewing previous statements. Our team working to restore all services as quickly as possible. Rest assured, our teams view this as urgent and are actively working to solve this for you.

We appreciate your patience and partnership. For immediate support, please contact us at support@billhighway.com.
Posted Mar 05, 2024 - 15:29 EST
This incident affected: Billhighway.co, API, CDN, Chapters, Docs, Forms, and Upload.