Billhighway Platform Alert Notification
Incident Report for Billhighway
Resolved
This incident has been resolved.
Posted Aug 27, 2024 - 18:12 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 01, 2024 - 11:20 EDT
Investigating
We are currently investigating this issue.
Posted Jul 31, 2024 - 14:47 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 31, 2024 - 14:36 EDT
Identified
A fix has been implemented and we are closely monitoring.
Posted Jul 31, 2024 - 14:35 EDT
Investigating
We are currently experiencing performance issues with the Billhighway reports and dashboards. Our technical teams are actively working to resolve this issue. We understand the importance of these reports to your operations and are striving to restore normal service as swiftly as possible.

We apologize for any inconvenience this may cause and appreciate your patience as we work towards a resolution. We expect to have this issue resolved as quickly as possible and will keep you updated on our progress.
Posted Jul 31, 2024 - 10:43 EDT
This incident affected: Billhighway.co, API, CDN, Chapters, Docs, Forms, and Upload.