Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 09, 2025 - 08:00 EST
Scheduled
On February 9th, Billhighway is performing scheduled maintenance from 8:00 AM to 12:00 PM Eastern. During the maintenance window, access to production (live) may be unavailable. If you have any questions or need immediate support, please contact us at support@billhighway.com
Posted Feb 03, 2025 - 18:54 EST
This scheduled maintenance affected: API, CDN, Chapters, Docs, Forms, and Upload.